summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Curses/Curses-1.06-r2.ebuild')
-rw-r--r--dev-perl/Curses/Curses-1.06-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Curses/Curses-1.06-r2.ebuild b/dev-perl/Curses/Curses-1.06-r2.ebuild
new file mode 100644
index 000000000000..c55aac95aaa7
--- /dev/null
+++ b/dev-perl/Curses/Curses-1.06-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Curses/Curses-1.06-r2.ebuild,v 1.1 2002/10/30 07:20:35 seemant Exp $
+
+inherit perl-module
+
+DESCRIPTION="Curses interface modules for Perl"
+HOMEPAGE="http://cpan.valueclick.com/authors/id/W/WP/WPS/${P}.readme"
+SRC_URI="http://cpan.valueclick.com/authors/id/W/WP/WPS/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="${DEPEND}
+ >=sys-libs/ncurses-5"
+
+mymake="/usr"
+myconf="${myconf} PANELS MENUS GEN"
+
+#This patch may or may not be backwards compatible with perl-5.6.1
+#Add gaurd as necessary...
+src_unpack() {
+ unpack ${A}
+ patch -p0 <${FILESDIR}/Curses-1.06-p5.8-fixes.diff || die
+}