summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-5.01.ebuild34
-rw-r--r--dev-ml/camlp5/files/digest-camlp5-5.013
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 04a682ce737e..d0220e68a943 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.4 2007/09/27 20:18:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.5 2007/10/08 08:50:56 aballier Exp $
+
+*camlp5-5.01 (08 Oct 2007)
+
+ 08 Oct 2007; Alexis Ballier <aballier@gentoo.org> +camlp5-5.01.ebuild:
+ version bump
*camlp5-5.00 (27 Sep 2007)
diff --git a/dev-ml/camlp5/camlp5-5.01.ebuild b/dev-ml/camlp5/camlp5-5.01.ebuild
new file mode 100644
index 000000000000..29e2ef534928
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.01.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.01.ebuild,v 1.1 2007/10/08 08:50:56 aballier Exp $
+
+inherit multilib eutils
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.10.0"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+
+ emake -j1 world.opt || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING
+}
diff --git a/dev-ml/camlp5/files/digest-camlp5-5.01 b/dev-ml/camlp5/files/digest-camlp5-5.01
new file mode 100644
index 000000000000..9072bc8a772a
--- /dev/null
+++ b/dev-ml/camlp5/files/digest-camlp5-5.01
@@ -0,0 +1,3 @@
+MD5 e08ba93009e3b8585e1920d7745121a5 camlp5-5.01.tgz 610154
+RMD160 93bb08a072d2322ccbc8a4a0e1a67035c69f142c camlp5-5.01.tgz 610154
+SHA256 ab83d306a823623e193e69a481f991f906116bc2c8990848a7e53550b197b0ba camlp5-5.01.tgz 610154