summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp4/ChangeLog8
-rw-r--r--dev-ml/camlp4/camlp4-4.02.0_p1-r1.ebuild (renamed from dev-ml/camlp4/camlp4-4.02.0_p1.ebuild)6
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-ml/camlp4/ChangeLog b/dev-ml/camlp4/ChangeLog
index f4fe6059e10b..6aeedf320aaa 100644
--- a/dev-ml/camlp4/ChangeLog
+++ b/dev-ml/camlp4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/camlp4
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp4/ChangeLog,v 1.1 2014/11/28 16:48:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp4/ChangeLog,v 1.2 2014/11/29 14:53:17 aballier Exp $
+
+*camlp4-4.02.0_p1-r1 (29 Nov 2014)
+
+ 29 Nov 2014; Alexis Ballier <aballier@gentoo.org> -camlp4-4.02.0_p1.ebuild,
+ +camlp4-4.02.0_p1-r1.ebuild:
+ install properly so that the lib is found
*camlp4-4.02.0_p1 (28 Nov 2014)
diff --git a/dev-ml/camlp4/camlp4-4.02.0_p1.ebuild b/dev-ml/camlp4/camlp4-4.02.0_p1-r1.ebuild
index 7580ad856568..034dbb7c5e93 100644
--- a/dev-ml/camlp4/camlp4-4.02.0_p1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.02.0_p1-r1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp4/camlp4-4.02.0_p1.ebuild,v 1.1 2014/11/28 16:48:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp4/camlp4-4.02.0_p1-r1.ebuild,v 1.1 2014/11/29 14:53:17 aballier Exp $
EAPI=5
-inherit multilib
-
MY_PV=${PV/_p/+}
MY_P=${PN}-${MY_PV}
@@ -27,7 +25,7 @@ S=${WORKDIR}/${P/_p/-}
src_configure() {
./configure \
--bindir="${ED}/usr/bin" \
- --libdir="${ED}/usr/$(get_libdir)" \
+ --libdir="${D}$(ocamlc -where)" \
--pkgdir="${D}$(ocamlc -where)" \
|| die
}