summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/log4cxx/log4cxx-0.9.5.ebuild')
-rw-r--r--dev-libs/log4cxx/log4cxx-0.9.5.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/dev-libs/log4cxx/log4cxx-0.9.5.ebuild b/dev-libs/log4cxx/log4cxx-0.9.5.ebuild
index af430c8a528d..ba11d4e28f4e 100644
--- a/dev-libs/log4cxx/log4cxx-0.9.5.ebuild
+++ b/dev-libs/log4cxx/log4cxx-0.9.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cxx/log4cxx-0.9.5.ebuild,v 1.5 2004/07/14 14:59:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cxx/log4cxx-0.9.5.ebuild,v 1.6 2005/01/06 13:49:00 ka0ttic Exp $
+
+inherit eutils
DESCRIPTION="Library of C++ classes for flexible logging to files, syslog and other destinations"
HOMEPAGE="http://log4cxx.sourceforge.net/"
@@ -9,24 +11,25 @@ SRC_URI="mirror://sourceforge/log4cxx/${P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~x86"
-
IUSE=""
+
DEPEND="virtual/libc
dev-libs/libxml2"
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fix-errno.diff
+}
src_compile() {
- ./autogen.sh
- econf || die "./configure failed"
- make || die
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
}
src_install () {
- make prefix=${D}/usr \
- datadir=${D}/usr/share \
- mandir=${D}/usr/share/man \
- docdir=${D}/usr/share/doc/${PF}/html \
- sysconfdir=${D}/etc install || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO
}