summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/php-4.3.11-r5.ebuild6
-rw-r--r--dev-lang/php/php-4.4.2-r2.ebuild6
-rw-r--r--dev-lang/php/php-4.4.2-r6.ebuild6
-rw-r--r--dev-lang/php/php-4.4.2.ebuild6
-rw-r--r--dev-lang/php/php-5.0.5-r5.ebuild6
-rw-r--r--dev-lang/php/php-5.1.4-r4.ebuild6
-rw-r--r--dev-lang/php/php-5.1.4.ebuild6
8 files changed, 27 insertions, 22 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index c66d97355b36..d1272b9a1dc1 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.109 2006/07/18 23:08:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.110 2006/07/20 14:26:12 chtekk Exp $
+
+ 20 Jul 2006; Luca Longinotti <chtekk@gentoo.org> php-4.3.11-r5.ebuild,
+ php-4.4.2.ebuild, php-4.4.2-r2.ebuild, php-4.4.2-r6.ebuild,
+ php-5.0.5-r5.ebuild, php-5.1.4.ebuild, php-5.1.4-r4.ebuild:
+ Fix bug #141098.
18 Jul 2006; Luca Longinotti <chtekk@gentoo.org> php-4.4.2-r6.ebuild,
php-5.1.4-r4.ebuild:
diff --git a/dev-lang/php/php-4.3.11-r5.ebuild b/dev-lang/php/php-4.3.11-r5.ebuild
index 99722b3df0a7..59f5b395d610 100644
--- a/dev-lang/php/php-4.3.11-r5.ebuild
+++ b/dev-lang/php/php-4.3.11-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.3.11-r5.ebuild,v 1.12 2006/07/14 16:04:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.3.11-r5.ebuild,v 1.13 2006/07/20 14:26:12 chtekk Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -29,13 +29,13 @@ CONCURRENTMODPHP_PATCH="${MY_PHP_PV}/opt/php${MY_PHP_PV}-concurrent_apache_modul
inherit php4_4-sapi apache-module
-want_apache
-
DESCRIPTION="The PHP language runtime engine: CLI, CGI and Apache SAPIs."
DEPEND="app-admin/php-toolkit"
RDEPEND="${DEPEND}"
+want_apache
+
# Fixed PCRE library for security issues, bug #102373
SRC_URI="${SRC_URI} http://gentoo.longitekk.com/php-pcrelib-new-secpatch.tar.bz2"
diff --git a/dev-lang/php/php-4.4.2-r2.ebuild b/dev-lang/php/php-4.4.2-r2.ebuild
index 73b0c8f97613..21945fbf3de4 100644
--- a/dev-lang/php/php-4.4.2-r2.ebuild
+++ b/dev-lang/php/php-4.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.2-r2.ebuild,v 1.11 2006/07/14 16:04:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.2-r2.ebuild,v 1.12 2006/07/20 14:26:12 chtekk Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -29,13 +29,13 @@ CONCURRENTMODPHP_PATCH="${MY_PHP_PV}/opt/php${MY_PHP_PV}-concurrent_apache_modul
inherit php4_4-sapi apache-module
-want_apache
-
DESCRIPTION="The PHP language runtime engine: CLI, CGI and Apache SAPIs."
DEPEND="app-admin/php-toolkit"
RDEPEND="${DEPEND}"
+want_apache
+
pkg_setup() {
PHPCONFUTILS_AUTO_USE=""
diff --git a/dev-lang/php/php-4.4.2-r6.ebuild b/dev-lang/php/php-4.4.2-r6.ebuild
index 7129a9fd14bf..858576984e3f 100644
--- a/dev-lang/php/php-4.4.2-r6.ebuild
+++ b/dev-lang/php/php-4.4.2-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.2-r6.ebuild,v 1.7 2006/07/18 23:08:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.2-r6.ebuild,v 1.8 2006/07/20 14:26:12 chtekk Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -29,13 +29,13 @@ CONCURRENTMODPHP_PATCH="${MY_PHP_PV}/opt/php${MY_PHP_PV}-concurrent_apache_modul
inherit php4_4-sapi apache-module
-want_apache
-
DESCRIPTION="The PHP language runtime engine: CLI, CGI and Apache SAPIs."
DEPEND="app-admin/php-toolkit"
RDEPEND="${DEPEND}"
+want_apache
+
pkg_setup() {
PHPCONFUTILS_AUTO_USE=""
diff --git a/dev-lang/php/php-4.4.2.ebuild b/dev-lang/php/php-4.4.2.ebuild
index 7e853768ec1c..f2fb6a70265f 100644
--- a/dev-lang/php/php-4.4.2.ebuild
+++ b/dev-lang/php/php-4.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.2.ebuild,v 1.12 2006/07/14 16:04:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.4.2.ebuild,v 1.13 2006/07/20 14:26:12 chtekk Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -29,13 +29,13 @@ CONCURRENTMODPHP_PATCH="${MY_PHP_PV}/opt/php${MY_PHP_PV}-concurrent_apache_modul
inherit php4_4-sapi apache-module
-want_apache
-
DESCRIPTION="The PHP language runtime engine: CLI, CGI and Apache SAPIs."
DEPEND="app-admin/php-toolkit"
RDEPEND="${DEPEND}"
+want_apache
+
pkg_setup() {
PHPCONFUTILS_AUTO_USE=""
diff --git a/dev-lang/php/php-5.0.5-r5.ebuild b/dev-lang/php/php-5.0.5-r5.ebuild
index a39a68f5289a..d0f2fd3a07da 100644
--- a/dev-lang/php/php-5.0.5-r5.ebuild
+++ b/dev-lang/php/php-5.0.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.0.5-r5.ebuild,v 1.15 2006/07/14 16:04:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.0.5-r5.ebuild,v 1.16 2006/07/20 14:26:12 chtekk Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -28,13 +28,13 @@ CONCURRENTMODPHP_PATCH="${MY_PHP_PV}/opt/php${MY_PHP_PV}-concurrent_apache_modul
inherit php5_0-sapi apache-module
-want_apache
-
DESCRIPTION="The PHP language runtime engine: CLI, CGI and Apache SAPIs."
DEPEND="app-admin/php-toolkit"
RDEPEND="${DEPEND}"
+want_apache
+
pkg_setup() {
PHPCONFUTILS_AUTO_USE=""
diff --git a/dev-lang/php/php-5.1.4-r4.ebuild b/dev-lang/php/php-5.1.4-r4.ebuild
index 4c90952343b1..b0bcbbae38d0 100644
--- a/dev-lang/php/php-5.1.4-r4.ebuild
+++ b/dev-lang/php/php-5.1.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.1.4-r4.ebuild,v 1.7 2006/07/18 23:08:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.1.4-r4.ebuild,v 1.8 2006/07/20 14:26:12 chtekk Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -29,13 +29,13 @@ CONCURRENTMODPHP_PATCH="${MY_PHP_PV}/opt/php${MY_PHP_PV}-concurrent_apache_modul
inherit php5_1-sapi apache-module
-want_apache
-
DESCRIPTION="The PHP language runtime engine: CLI, CGI and Apache SAPIs."
DEPEND="app-admin/php-toolkit"
RDEPEND="${DEPEND}"
+want_apache
+
pkg_setup() {
PHPCONFUTILS_AUTO_USE=""
diff --git a/dev-lang/php/php-5.1.4.ebuild b/dev-lang/php/php-5.1.4.ebuild
index 665ad7817116..64ca6f722488 100644
--- a/dev-lang/php/php-5.1.4.ebuild
+++ b/dev-lang/php/php-5.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.1.4.ebuild,v 1.12 2006/07/14 16:04:37 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.1.4.ebuild,v 1.13 2006/07/20 14:26:12 chtekk Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -29,13 +29,13 @@ CONCURRENTMODPHP_PATCH="${MY_PHP_PV}/opt/php${MY_PHP_PV}-concurrent_apache_modul
inherit php5_1-sapi apache-module
-want_apache
-
DESCRIPTION="The PHP language runtime engine: CLI, CGI and Apache SAPIs."
DEPEND="app-admin/php-toolkit"
RDEPEND="${DEPEND}"
+want_apache
+
pkg_setup() {
PHPCONFUTILS_AUTO_USE=""