summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/gentoo-bashcomp')
-rw-r--r--app-shells/gentoo-bashcomp/ChangeLog8
-rw-r--r--app-shells/gentoo-bashcomp/Manifest14
-rw-r--r--app-shells/gentoo-bashcomp/files/digest-gentoo-bashcomp-200503291
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20050329.ebuild29
4 files changed, 40 insertions, 12 deletions
diff --git a/app-shells/gentoo-bashcomp/ChangeLog b/app-shells/gentoo-bashcomp/ChangeLog
index 89d2589fbf0c..1f1e8c8553fe 100644
--- a/app-shells/gentoo-bashcomp/ChangeLog
+++ b/app-shells/gentoo-bashcomp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/gentoo-bashcomp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.2 2005/03/25 16:51:48 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.3 2005/03/29 16:24:38 ka0ttic Exp $
+
+*gentoo-bashcomp-20050329 (29 Mar 2005)
+
+ 29 Mar 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +gentoo-bashcomp-20050329.ebuild:
+ Lots of changes; faster emerge completion. See installed ChangeLog.
25 Mar 2005; Aaron Walker <ka0ttic@gentoo.org>
gentoo-bashcomp-20050316.ebuild:
diff --git a/app-shells/gentoo-bashcomp/Manifest b/app-shells/gentoo-bashcomp/Manifest
index b4ca977702a4..6c68373aabc2 100644
--- a/app-shells/gentoo-bashcomp/Manifest
+++ b/app-shells/gentoo-bashcomp/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 faaa1919cdbb2161df7b1a99b5f2c45b gentoo-bashcomp-20050329.ebuild 1036
MD5 faaa1919cdbb2161df7b1a99b5f2c45b gentoo-bashcomp-20050316.ebuild 1036
-MD5 7d2de1d007aeb3e3e435ffbcb99dbc7f ChangeLog 550
+MD5 3329cc439a924edabadb990bee124cce ChangeLog 747
MD5 99ce5509db4b50f28a1f6675f8c09b2b metadata.xml 258
MD5 d43bd783050ae3fff7f64a93181fe15f files/digest-gentoo-bashcomp-20050316 76
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCREG/EZCkKN40op4RAlCNAKC5r9h+Nstzf4peUf6G9fzPs9uNMwCgronv
-LjRlEJHcBmW84y9Npaj9FcQ=
-=OmGj
------END PGP SIGNATURE-----
+MD5 062bd4231ac362ed01d81442019db5f3 files/digest-gentoo-bashcomp-20050329 76
diff --git a/app-shells/gentoo-bashcomp/files/digest-gentoo-bashcomp-20050329 b/app-shells/gentoo-bashcomp/files/digest-gentoo-bashcomp-20050329
new file mode 100644
index 000000000000..b54e9bcc7933
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/files/digest-gentoo-bashcomp-20050329
@@ -0,0 +1 @@
+MD5 c6d3afd884a4c22ba091f3121999f994 gentoo-bashcomp-20050329.tar.bz2 18175
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20050329.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20050329.ebuild
new file mode 100644
index 000000000000..d9393a8af8f0
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20050329.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/gentoo-bashcomp-20050329.ebuild,v 1.1 2005/03/29 16:24:38 ka0ttic Exp $
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="http://developer.berlios.de/projects/gentoo-bashcomp/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-completion-20050121-r3"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ local g="${ROOT}/etc/bash_completion.d/gentoo"
+ if [[ -e "${g}" && ! -L "${g}" ]] ; then
+ echo
+ ewarn "The gentoo completion functions have moved to /usr/share/bash-completion."
+ ewarn "Please run etc-update to replace /etc/bash_completion.d/gentoo with a symlink."
+ echo
+ fi
+}