summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/yaps')
-rw-r--r--app-mobilephone/yaps/ChangeLog8
-rw-r--r--app-mobilephone/yaps/files/yaps-0.96-gentoo.diff56
-rw-r--r--app-mobilephone/yaps/yaps-0.96-r3.ebuild84
3 files changed, 147 insertions, 1 deletions
diff --git a/app-mobilephone/yaps/ChangeLog b/app-mobilephone/yaps/ChangeLog
index 3ff57b3651e3..fe929e9576d6 100644
--- a/app-mobilephone/yaps/ChangeLog
+++ b/app-mobilephone/yaps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/yaps
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.20 2008/10/26 22:58:47 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.21 2008/10/27 01:58:52 sbriesen Exp $
+
+*yaps-0.96-r3 (27 Oct 2008)
+
+ 27 Oct 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/yaps-0.96-gentoo.diff, +yaps-0.96-r3.ebuild:
+ revision bump to include latest capi enabled yaps.
26 Oct 2008; Stefan Briesenick <sbriesen@gentoo.org> yaps-0.96-r2.ebuild:
fixed CC/CXX variable handling using tc-getCC/CXX, solving bug #243692.
diff --git a/app-mobilephone/yaps/files/yaps-0.96-gentoo.diff b/app-mobilephone/yaps/files/yaps-0.96-gentoo.diff
new file mode 100644
index 000000000000..98f528c30116
--- /dev/null
+++ b/app-mobilephone/yaps/files/yaps-0.96-gentoo.diff
@@ -0,0 +1,56 @@
+--- Config.orig 2005-06-02 20:28:35.000000000 +0200
++++ Config 2005-10-16 15:13:32.000000000 +0200
+@@ -24,9 +24,9 @@
+ # Name of local configuration file (location is $HOME.)
+ YAPS_LCFGFILE = .yapsrc
+ # Directory for installing the binary
+-YAPS_BINDIR = /usr/local/bin
++YAPS_BINDIR = /usr/bin
+ # Directory for optional support files
+-YAPS_LIBDIR = /usr/local/lib/yaps
++YAPS_LIBDIR = /usr/lib/yaps
+ # User/Group/Mode for yaps
+ YAPS_USER = bin
+ YAPS_GROUP = uucp
+@@ -43,12 +43,12 @@
+ ifdef SLANG
+ LDEFS += -DSCRIPT_SLANG
+ LLIBS += -lslang
+-MATH = True
++#MATH = True
+ endif
+ ifdef LUA
+ LDEFS += -DSCRIPT_LUA
+-LLIBS += -llualib -llua
+-MATH = True
++LLIBS += `pkg-config --libs lua`
++#MATH = True
+ endif
+ ifdef MATH
+ LLIBS += -lm
+--- Makefile.orig 2005-06-02 20:33:27.000000000 +0200
++++ Makefile 2005-10-16 15:13:32.000000000 +0200
+@@ -33,19 +33,19 @@
+ lynx -cfg=/dev/null -nolist -dump $< > $@
+
+ install: $(DSTFLE) $(CFGFILE)
+- if [ ! -d $(YAPS_LIBDIR) ]; then \
+- install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(YAPS_LIBDIR) ; \
++ if [ ! -d $(DESTDIR)$(YAPS_LIBDIR) ]; then \
++ install -d -m 755 $(DESTDIR)$(YAPS_LIBDIR) ; \
+ fi
+ @if [ -f contrib/Makefile ]; then \
+ $(MAKE) -C contrib install ; \
+ fi
+
+ $(DSTFLE): yaps
+- install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $@
++ install -m $(YAPS_MODE) -s yaps $(DESTDIR)$@
+
+ $(CFGFILE): yaps.rc
+ @if [ ! -f $@ ]; then \
+- install -o $(YAPS_RCUSER) -g $(YAPS_RCGROUP) -m $(YAPS_RCMODE) -s yaps.rc $@ ; \
++ install -m $(YAPS_RCMODE) -s yaps.rc $(DESTDIR)$@ ; \
+ fi
+
+ clean:
diff --git a/app-mobilephone/yaps/yaps-0.96-r3.ebuild b/app-mobilephone/yaps/yaps-0.96-r3.ebuild
new file mode 100644
index 000000000000..b9934ce5730b
--- /dev/null
+++ b/app-mobilephone/yaps/yaps-0.96-r3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/yaps-0.96-r3.ebuild,v 1.1 2008/10/27 01:58:52 sbriesen Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Yet Another Pager Software (optional with CAPI support)"
+HOMEPAGE="ftp://sunsite.unc.edu/pub/Linux/apps/serialcomm/machines/"
+SRC_URI="capi? ( ftp://ftp.melware.net/capi4yaps/${P}.c4.tgz )
+ !capi? ( ftp://sunsite.unc.edu/pub/Linux/apps/serialcomm/machines/${P}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="capi lua slang unicode"
+
+RDEPEND="capi? ( net-dialup/capi4k-utils )
+ slang? ( >=sys-libs/slang-1.4 )
+ lua? ( dev-lang/lua )"
+DEPEND="${RDEPEND}
+ !capi? ( sys-apps/sed )
+ lua? ( dev-util/pkgconfig )"
+
+pkg_setup() {
+ if ! use capi; then
+ ewarn
+ ewarn "You are now compiling some *very* old and unmaintained stuff!"
+ ewarn
+ ewarn "YAPS with CAPI 2.0 support is actively maintained, but needs"
+ ewarn "net-dialup/capi4k-utils installed. But I advice you to use"
+ ewarn "this version, since it can still be used with an ordinary"
+ ewarn "modem (that's what you probably wanted). So just add 'capi'"
+ ewarn "to your USE flags to get the new and maintained version."
+ ewarn
+ ebeep
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ use capi && mv -f "${S}.c4" "${S}"
+ cd "${S}"
+
+ # apply patches
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+
+ # fix compile warning
+ use capi || \
+ sed -i -e 's:^\(.*\)\(<stdlib.h>\):\1\2\n\1<string.h>:g' scr.c
+
+ # if specified, convert all relevant files from latin1 to UTF-8
+ if use unicode; then
+ for i in yaps.doc; do
+ einfo "Converting '${i}' to UTF-8"
+ iconv -f latin1 -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use lua && myconf="${myconf} LUA=True"
+ use slang && myconf="${myconf} SLANG=True"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" ${myconf} || die "emake failed"
+}
+
+src_install() {
+ dobin yaps
+ insinto /etc
+ doins yaps.rc
+ keepdir /usr/lib/yaps
+ doman yaps.1
+ dohtml yaps.html
+ dodoc BUGREPORT COPYRIGHT README yaps.lsm yaps.doc
+ newdoc contrib/README README.contrib
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/{m2y.pl,tap.sl}
+}
+
+pkg_postinst() {
+ elog
+ elog "Please edit /etc/yaps.rc to suit your needs."
+ elog
+}