summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/wyrd')
-rw-r--r--app-misc/wyrd/ChangeLog6
-rw-r--r--app-misc/wyrd/Manifest3
-rw-r--r--app-misc/wyrd/files/wyrd-1.2.0-no-remind-version-check.patch24
-rw-r--r--app-misc/wyrd/wyrd-1.2.0.ebuild11
4 files changed, 41 insertions, 3 deletions
diff --git a/app-misc/wyrd/ChangeLog b/app-misc/wyrd/ChangeLog
index 2dc8bb81dc16..14c0c1cb44d5 100644
--- a/app-misc/wyrd/ChangeLog
+++ b/app-misc/wyrd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/wyrd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/ChangeLog,v 1.4 2006/01/15 18:02:13 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/ChangeLog,v 1.5 2006/01/15 18:38:24 twp Exp $
+
+ 15 Jan 2006; Tom Payne <twp@gentoo.org>
+ +files/wyrd-1.2.0-no-remind-version-check.patch, wyrd-1.2.0.ebuild:
+ Remove broken remind version check.
*wyrd-1.2.0 (15 Jan 2006)
diff --git a/app-misc/wyrd/Manifest b/app-misc/wyrd/Manifest
index c8e78fcbcf09..1c8383f9644a 100644
--- a/app-misc/wyrd/Manifest
+++ b/app-misc/wyrd/Manifest
@@ -1,6 +1,7 @@
MD5 2e5c3558df34a7adcd4bbb06e788b4cf ChangeLog 691
MD5 141d7e8a8e5f82f55bd83bbb664a46d9 files/digest-wyrd-1.1.1 62
MD5 b8d6116a6882a07c79a6d9b056347430 files/digest-wyrd-1.2.0 62
+MD5 409adbb2f65df5c302402508e795de71 files/wyrd-1.2.0-no-remind-version-check.patch 932
MD5 4a6a953879a42aee5735cb2434ae754d metadata.xml 369
MD5 f39bfdc091ab5e5702097d597b83d01d wyrd-1.1.1.ebuild 738
-MD5 a2a162767f32eb5d388d9d19d4e9984e wyrd-1.2.0.ebuild 705
+MD5 701e2aebecdc60bfabaa721bfce0b92c wyrd-1.2.0.ebuild 848
diff --git a/app-misc/wyrd/files/wyrd-1.2.0-no-remind-version-check.patch b/app-misc/wyrd/files/wyrd-1.2.0-no-remind-version-check.patch
new file mode 100644
index 000000000000..e6736a81b23f
--- /dev/null
+++ b/app-misc/wyrd/files/wyrd-1.2.0-no-remind-version-check.patch
@@ -0,0 +1,24 @@
+diff -Naur wyrd-1.2.0/configure.in wyrd/configure.in
+--- wyrd-1.2.0/configure.in 2005-11-20 09:16:35.000000000 +0100
++++ wyrd/configure.in 2006-01-15 19:32:17.000000000 +0100
+@@ -150,20 +150,6 @@
+ AC_MSG_ERROR(Cannot find a curses library. Perhaps you failed to install an ncurses development package?)
+ fi
+
+-# check Remind version
+-REMINDVERSION=`remind --help 2> /dev/null | head -n 2 | tail -n 1 | cut -d ' ' -f 2`
+-echo "remind version is $REMINDVERSION"
+-REMMAJORVERSION=`echo $REMINDVERSION | cut -d '.' -f 1`
+-REMMINORVERSION=`echo $REMINDVERSION | cut -d '.' -f 2`
+-REMFIXVERSION=`echo $REMINDVERSION | cut -d '.' -f 3`
+-if test $REMMAJORVERSION -lt 3 ; then
+- AC_MSG_WARN(Wyrd requires Remind version 03.00.24 or greater.)
+-else
+- if test $REMFIXVERSION -lt 24 ; then
+- AC_MSG_WARN(Wyrd requires Remind version 03.00.24 or greater.)
+- fi
+-fi
+-
+ # substitutions to perform
+ AC_SUBST(OCAMLC)
+ AC_SUBST(OCAMLOPT)
diff --git a/app-misc/wyrd/wyrd-1.2.0.ebuild b/app-misc/wyrd/wyrd-1.2.0.ebuild
index 0b9bfa368212..d87783508fd9 100644
--- a/app-misc/wyrd/wyrd-1.2.0.ebuild
+++ b/app-misc/wyrd/wyrd-1.2.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.2.0.ebuild,v 1.1 2006/01/15 18:02:13 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.2.0.ebuild,v 1.2 2006/01/15 18:38:24 twp Exp $
+
+inherit eutils
DESCRIPTION="Text-based front-end to Remind"
HOMEPAGE="http://www.eecs.umich.edu/~pelzlpj/wyrd/"
@@ -15,7 +17,14 @@ DEPEND=">=dev-lang/ocaml-3.08
sys-libs/ncurses
>=x11-misc/remind-03.00.24"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-no-remind-version-check.patch
+}
+
src_compile() {
+ autoreconf || die "autoreconf failed."
+
econf || die "configure failed."
emake || die "make failed."