summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/ChangeLog7
-rw-r--r--app-i18n/anthy/anthy-9100b.ebuild70
-rw-r--r--app-i18n/anthy/files/digest-anthy-9100b3
3 files changed, 79 insertions, 1 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index 3cc3036d0c13..b9f2dfaf6dec 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.105 2007/09/09 13:06:36 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.106 2007/09/17 14:12:57 hattya Exp $
+
+*anthy-9100b (17 Sep 2007)
+
+ 17 Sep 2007; Akinori Hattori <hattya@gentoo.org> +anthy-9100b.ebuild:
+ new upstream release.
09 Sep 2007; Akinori Hattori <hattya@gentoo.org> anthy-9100.ebuild:
stable on ia64.
diff --git a/app-i18n/anthy/anthy-9100b.ebuild b/app-i18n/anthy/anthy-9100b.ebuild
new file mode 100644
index 000000000000..f34af92c7115
--- /dev/null
+++ b/app-i18n/anthy/anthy-9100b.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-9100b.ebuild,v 1.1 2007/09/17 14:12:57 hattya Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/27175/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+DEPEND="!app-i18n/anthy-ss
+ emacs? ( virtual/emacs )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ sed -i /placename/a"read ${cannadicdir}/nichan.ctd" \
+ mkworddic/dict.args.in
+ fi
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use emacs || myconf="EMACS=no"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
+
+ dodoc AUTHORS DIARY NEWS README ChangeLog
+
+ docinto doc
+ rm doc/Makefile*
+ dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy/files/digest-anthy-9100b b/app-i18n/anthy/files/digest-anthy-9100b
new file mode 100644
index 000000000000..65c72032e27c
--- /dev/null
+++ b/app-i18n/anthy/files/digest-anthy-9100b
@@ -0,0 +1,3 @@
+MD5 0ad3873646255a2ca1c8576350fabb27 anthy-9100b.tar.gz 3988712
+RMD160 7a89f96c6bdfc3704b80d3d41a9a54db4ac52af7 anthy-9100b.tar.gz 3988712
+SHA256 e2b4854938094f4a86ae2910c9239693d34b1de842596d7ad3e990c4052ac444 anthy-9100b.tar.gz 3988712