summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/ChangeLog11
-rw-r--r--app-emacs/python-mode/files/60python-mode-gentoo-5.1.el10
-rw-r--r--app-emacs/python-mode/python-mode-5.1.0.ebuild25
3 files changed, 44 insertions, 2 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 295f33ae1743..a75eb6c304f6 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/python-mode
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.36 2008/09/20 21:09:47 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.37 2009/04/16 05:31:28 fauli Exp $
+
+*python-mode-5.1.0 (16 Apr 2009)
+
+ 16 Apr 2009; Christian Faulhammer <fauli@gentoo.org>
+ +files/60python-mode-gentoo-5.1.el, +python-mode-5.1.0.ebuild:
+ version bump, taken from Emacs overlay. Major rework of the mode, but
+ dropped some features, like doctest-mode which has its own ebuild now
20 Sep 2008; Ulrich Mueller <ulm@gentoo.org> -python-mode-1.0.ebuild:
Remove old.
diff --git a/app-emacs/python-mode/files/60python-mode-gentoo-5.1.el b/app-emacs/python-mode/files/60python-mode-gentoo-5.1.el
new file mode 100644
index 000000000000..0b3aeae41681
--- /dev/null
+++ b/app-emacs/python-mode/files/60python-mode-gentoo-5.1.el
@@ -0,0 +1,10 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'python-mode "python-mode" "Python editing mode." t)
+(autoload 'jython-mode "python-mode" "Python editing mode." t)
+(autoload 'py-shell "python-mode" "Start an interactive Python interpreter in another window." t)
+
+(add-to-list 'auto-mode-alist '("\\.py$" . python-mode))
+
+(add-to-list 'interpreter-mode-alist '("python" . python-mode))
+(add-to-list 'interpreter-mode-alist '("jython" . jython-mode))
diff --git a/app-emacs/python-mode/python-mode-5.1.0.ebuild b/app-emacs/python-mode/python-mode-5.1.0.ebuild
new file mode 100644
index 000000000000..37bb266ee90f
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-5.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-5.1.0.ebuild,v 1.1 2009/04/16 05:31:28 fauli Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+# taken from http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}.el"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+SITEFILE=50${PN}-gentoo-5.1.el
+
+pkg_postinst() {
+ elog "Note that doctest support is now split out to app-emacs/doctest-mode."
+}