summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ecb/ecb-2.24.ebuild')
-rw-r--r--app-emacs/ecb/ecb-2.24.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-emacs/ecb/ecb-2.24.ebuild b/app-emacs/ecb/ecb-2.24.ebuild
deleted file mode 100644
index 0cb55f085a7e..000000000000
--- a/app-emacs/ecb/ecb-2.24.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-2.24.ebuild,v 1.9 2005/07/16 20:07:46 josejx Exp $
-
-inherit elisp
-
-DESCRIPTION="ECB is a source code browser for Emacs"
-HOMEPAGE="http://ecb.sourceforge.net/"
-SRC_URI="mirror://sourceforge/ecb/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="java"
-DEPEND="virtual/emacs
- || (
- ( >=app-emacs/speedbar-0.14_beta4
- >=app-emacs/semantic-1.4
- >=app-emacs/eieio-0.17
- )
- app-emacs/cedet
- )
- java? ( app-emacs/jde )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i -e "s%./info-help%../../../info%" \
- -e "s%./html-help%../../../doc/${P}/html%" \
- -e "/defconst/s%ecb.info%ecb.info.gz%" \
- ecb-help.el
-}
-
-src_compile() {
- local my_loadpath="${SITELISP}/semantic ${SITELISP}/eieio"
- use java \
- && my_loadpath="${my_loadpath} ${SITELISP}/elib ${SITELISP}/jde/lisp"
- make CEDET='' \
- LOADPATH="${my_loadpath}" \
- || die
- make online-help \
- LOADPATH="${my_loadpath}" \
- || die
-}
-
-src_install() {
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install ${FILESDIR}/70ecb-gentoo.el
- dodoc NEWS README RELEASE_NOTES
- doinfo info-help/ecb.info*
- dohtml html-help/*.html
-}