summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-15 04:58:28 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-15 04:58:28 +0000
commitda66e1b7e78f5988559ec34f7152353ac9e916a1 (patch)
tree8468ea49e5f3b20d65a8a78a41458ce85c06c1e4 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-da66e1b7e78f5988559ec34f7152353ac9e916a1.tar.gz
gentoo-2-da66e1b7e78f5988559ec34f7152353ac9e916a1.tar.bz2
gentoo-2-da66e1b7e78f5988559ec34f7152353ac9e916a1.zip
Version bump, run testsuite.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pexpect/ChangeLog7
-rw-r--r--dev-python/pexpect/pexpect-3.2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/pexpect/ChangeLog b/dev-python/pexpect/ChangeLog
index bc2fa6893259..4720f934d861 100644
--- a/dev-python/pexpect/ChangeLog
+++ b/dev-python/pexpect/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pexpect
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/ChangeLog,v 1.67 2014/04/01 05:06:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/ChangeLog,v 1.68 2014/04/15 04:58:28 radhermit Exp $
+
+*pexpect-3.2 (15 Apr 2014)
+
+ 15 Apr 2014; Tim Harder <radhermit@gentoo.org> +pexpect-3.2.ebuild:
+ Version bump, run testsuite.
01 Apr 2014; Mike Gilbert <floppym@gentoo.org> pexpect-3.1.ebuild:
Add python3.4.
diff --git a/dev-python/pexpect/pexpect-3.2.ebuild b/dev-python/pexpect/pexpect-3.2.ebuild
new file mode 100644
index 000000000000..b62a7a7ac50f
--- /dev/null
+++ b/dev-python/pexpect/pexpect-3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/pexpect-3.2.ebuild,v 1.1 2014/04/15 04:58:28 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+HOMEPAGE="http://pexpect.sourceforge.net/ http://pypi.python.org/pypi/pexpect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-fbsd ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ . test.env || die
+ "${PYTHON}" tools/testall.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}