summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-07-13 19:56:02 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-07-13 19:56:02 +0000
commitfd25a76ec0ceed2223e6d6c22afb9a46c6e237cb (patch)
tree18aff83dc8789a11e8a5a744c441d0d5f0a57bde
parentRemoved postconf from example spec files. (diff)
downloadgentoo-fd25a76ec0ceed2223e6d6c22afb9a46c6e237cb.tar.gz
gentoo-fd25a76ec0ceed2223e6d6c22afb9a46c6e237cb.tar.bz2
gentoo-fd25a76ec0ceed2223e6d6c22afb9a46c6e237cb.zip
Removed gcloop. It has been deprecated for some time now.
-rw-r--r--src/catalyst/ChangeLog7
-rw-r--r--src/catalyst/examples/livecd-stage2_template.spec1
-rw-r--r--src/catalyst/livecd/runscript/default-runscript.sh17
3 files changed, 7 insertions, 18 deletions
diff --git a/src/catalyst/ChangeLog b/src/catalyst/ChangeLog
index 990c95bcd4..b64d72c81a 100644
--- a/src/catalyst/ChangeLog
+++ b/src/catalyst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gentoo/src/catalyst
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo/src/catalyst/Attic/ChangeLog,v 1.198.2.102 2005/07/13 16:52:00 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo/src/catalyst/Attic/ChangeLog,v 1.198.2.103 2005/07/13 19:56:02 wolf31o2 Exp $
+
+ 13 Jul 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ examples/livecd-stage2_template.spec,
+ livecd/runscript/default-runscript.sh:
+ Removed gcloop. It has been deprecated for some time now.
13 Jul 2005; Chris Gianelloni <wolf31o2@gentoo.org>
examples/livecd-stage2_template.spec:
diff --git a/src/catalyst/examples/livecd-stage2_template.spec b/src/catalyst/examples/livecd-stage2_template.spec
index af1216aa4b..c856d61471 100644
--- a/src/catalyst/examples/livecd-stage2_template.spec
+++ b/src/catalyst/examples/livecd-stage2_template.spec
@@ -63,7 +63,6 @@ portage_confdir:
# zisofs - This uses in-kernel compression and is supported on all platforms.
# normal - This creates a loop without compression.
# noloop - This copies the files to the CD directly, withuot using a loopback.
-# gcloop - This is deprecated and only provided for backwards compatibility.
# example:
# livecd/cdfstype: squashfs
livecd/cdfstype:
diff --git a/src/catalyst/livecd/runscript/default-runscript.sh b/src/catalyst/livecd/runscript/default-runscript.sh
index 8d530d982a..5a75c0f130 100644
--- a/src/catalyst/livecd/runscript/default-runscript.sh
+++ b/src/catalyst/livecd/runscript/default-runscript.sh
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo/src/catalyst/livecd/runscript/Attic/default-runscript.sh,v 1.25.2.6 2005/06/28 22:28:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo/src/catalyst/livecd/runscript/Attic/default-runscript.sh,v 1.25.2.7 2005/07/13 19:56:02 wolf31o2 Exp $
#return codes to be used by archscript
die() {
@@ -22,9 +22,6 @@ case ${clst_livecd_cdfstype} in
squashfs)
cmdline_opts="looptype=squashfs loop=/livecd.squashfs"
;;
- gcloop)
- cmdline_opts="looptype=gcloop loop=/livecd.gcloop"
- ;;
esac
source ${clst_livecd_archscript}
@@ -76,14 +73,6 @@ create_noloop() {
}
-create_gcloop() {
- create_normal_loop
- compress_gcloop_ucl -b 131072 -c 10 "${clst_cdroot_path}/livecd.loop" "${clst_cdroot_path}/livecd.gcloop" || die "compress_gcloop_ucl failed, did you emerge gcloop?"
- rm -f "${clst_cdroot_path}/livecd.loop"
- # only a gcloop image should exist in cdroot path
-
-}
-
create_squashfs() {
echo "Creating squashfs..."
mksquashfs "${clst_chroot_path}" "${clst_cdroot_path}/livecd.squashfs" -noappend || die "mksquashfs failed, did you emerge squashfs-tools?"
@@ -214,10 +203,6 @@ case $1 in
then
create_noloop
loopret=$?
- elif [ "${clst_livecd_cdfstype}" = "gcloop" ]
- then
- create_gcloop
- loopret=$?
elif [ "${clst_livecd_cdfstype}" = "squashfs" ]
then
create_squashfs